Bug 7375 - Update minimum version of Perl to 5.10
- Change the installer script to look for at least 5.10/5.010000
- Change the template to ask for the correct version
To test:
- Run through the webinstaller on 5.10 or newer and check that there are
no errors.
- Ideally: Run through the webinstaller on an older version than 5.10 and
check that there *is* an error, asking for 5.10 or newer.
Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
(cherry picked from commit 1c04a98400)
Signed-off-by: Chris Nighswonger <chris.nighswonger@gmail.com>
This commit is contained in:
parent
5638111e53
commit
da8e62028f
|
|
@ -59,7 +59,7 @@ if ( $step && $step == 1 ) {
|
|||
$template->param( language => 1 );
|
||||
$template->param( 'checkmodule' => 1 ); # we start with the assumption that there are no problems and set this to 0 if there are
|
||||
|
||||
unless ( $] >= 5.008008 ) { # Bug 4505
|
||||
unless ( $] >= 5.010000 ) { # Bug 7375
|
||||
$template->param( problems => 1, perlversion => 1, checkmodule => 0 );
|
||||
}
|
||||
|
||||
|
|
|
|||
|
|
@ -49,8 +49,8 @@ listed, please inform your systems administrator.</p>
|
|||
<p>I encountered some problems.</p>
|
||||
<ul>
|
||||
[% IF ( perlversion ) %]
|
||||
<li>Your perl version seems to be obsolete.
|
||||
Please upgrade to a newer version of Perl (at least Version 5.006001).</li>
|
||||
<li>Your Perl version seems to be obsolete.
|
||||
Please upgrade to a newer version of Perl (at least Version 5.10).</li>
|
||||
[% END %]
|
||||
</ul>
|
||||
[% END %]
|
||||
|
|
|
|||
Loading…
Reference in New Issue